I was taking notes and I've written:
Our "State" class can either be "StartState" or "StopState" and depending on that we'll have different functionalities
Is that correct? Idk why but it doesn't sound so xD
Thanks for your time and please feel free to correct any other mistakes I've made!
Have a nice day!