I'm trying to name a function in a software package. Let's start with some backgrounds. The package provides supplemental functions to multiple upstream packages that train random forests. To avoid duplicated code, I use a function A to convert random forest objects from different upstream vendors into an intermediate object, and then have other functions B1, B2, ... operate on it. The name for Bs have been decided, i.e.
trainsetBias. However, I'm struggling to give A a good name.
I have come up with
transtionRF ("RF" is a widely understood abbr. for "random forest", but them fail to capture A's functionality to take objects of different types, and then convert them to something of a common structure. I would like to emphasis its Polymorphism nature in the name.
Other candidates include
adapterRF, but it seems to implies the resultant object is itself a middleware/adapter that can act on something else, instead of the output of a middleware/adapter. If I were to use this name, then Bs need to be
trainsetBiasCalculator for consistency, which would be too verbose.
To sum up, what do you call the output of a middleware/adapter that takes different objects, and then convert them to intermediate objects with the same structure? It's fine to answer with a phrase, but please keep it no longer than 15 characters.