0

I was having this discussion with a colleague on naming a programming function. Which gives us a list of logs that we call the "audit trail".

I told my colleague that it would be incorrect to call said function "list audit trail" as you can't really list something that is singular. Proposing instead "get audit trail" or "list audit trail logs".

My colleague tells me that an audit trail is already a collection of things therefore "list audit trail" would be correct. What's the rule here?

3
  • Perhaps you mean enumerate the audit trail? An enumeration might look like: “The audit trail has three members. It starts with (a, b, c), which is followed by (c, d), and then, most recently, (e, f, g, h).” Commented May 17 at 15:18
  • You'd usually list the items, not a list itself, so list audit trail logs (or entries) is certainly correct. Personally I wouldn't balk too much at listing a log (by analogy to listing a program, like in the old BASIC interpreters), but it's more jargon-y. Commented May 17 at 19:28
  • (that said, I'd probably just go with GetAuditTrail if the function returns the audit trail, rather than displays it). Commented May 17 at 19:32

1 Answer 1

0

If an "audit trail" is a higher level concept, composed of multiple logs, then on some level it may be logically acceptable to say "list audit trail".

Nevertheless, that creates grammatical confusion and might sound awkward, regardless of whether it's correct or not. Usually we "list files" (plural). The idea of "listing" suggests a plural object.

The problem could be resolved in multiple ways.

  • Change the name of "audit_trail" to "audit_trail_logs" so that it's plural and reflects the underlying reality more closely. Then treat the variable as a plural noun. "list_audit_trail_logs" "get_audit_trail_logs".

  • Or, as you have proposed, use "get_audit_trail" and "list_audit_trail_logs". Maciej mentioned in the comments that we'd need to know if the function returns the list, or displays the list, since that should be factored into the naming decision. It's fine to "get" a singular object.

I suspect the formation and usage of plural nouns in Portuguese is similar to English. How would you resolve this in Portuguese?

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .