Yeah, the title isn't the smoothest, sorry about that.
I'm programming a property and I want to name it in the most intuitive way. Extra bonus if it's a short one. Please note that there's no emphasis whatsoever on the term being broadly known, self-explanatory nor trivially interpreted. It's good if some or all of the properties are possible to achieve but it's by no means a requirement.
There's a method for computing an area to a polygon and it's called Area. However, it's being accessed very frequently so I've improved it so it doesn't need to compute the area every time. Only if the area hasn't been computed (or needs being recalculated), the actual calculation will take place. In every other occasion, I retrieve it from the pre-computed storage.
And here's the linguistic issue. Naturally, I'd call the method
ComputeIfNeededThenStoreAndAfterwardsRetrieveArea
but that's only nice to the eyes of a computer, not a human. I could, of course, be vague on the actual implementation details and go
ComputeArea
or maybe even
ComputeCacheableArea
but it seems to me plausible that there might be a verb conveying that precise message with a fewer and shorter words. Is there such a verb, please?